博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
三角形问题
阅读量:5231 次
发布时间:2019-06-14

本文共 1122 字,大约阅读时间需要 3 分钟。

问题:You are given the side lengths of a triangle, determine is it an acute triangle, right triangle or obtuse triangle.

 
Input
The first line contains an integer T indicating the number of test cases.
For each test case, there is a single line contains three integer A, B and C indicating the side lengths of the triangle. (You can assume it is a valid triangle)
Technical Specification
1. 1 <= T <= 50
2. 1 <= A,B,C <= 100
 
Output
For each test case, output the case number first, then output "Acute triangle", "Right triangle" or "Obtuse triangle".
 
Sample Input
3
2 2 2
4 8 5
3 4 5
Sample Output
Case 1: Acute triangle
Case 2: Obtuse triangle
Case 3: Right triangle

 

回答:

#include<iostream>

using namespace std;
int main()
{
    int n, p=1;
    scanf("%d", &n);
    while(n--)
    {
        int a, b, c;
        scanf("%d%d%d", &a, &b, &c);
        int t;
        if(a > b)
        {
            t=a;
            a=b;
            b=t;
        }
        if(b > c)
        {
            t=b;
            b=c;
            c=t;
        }
        if(a > b)
        {
            t=a;
            a=b;
            b=t;
        }
        printf("Case %d: ", p++);
        if(a*a+b*b == c*c)
            printf("Right triangle\n");
        else if(a*a+b*b > c*c)
            printf("Acute triangle\n");
        else
            printf("Obtuse triangle\n");
    }
    return 0;
}

转载于:https://www.cnblogs.com/benchao/p/4606292.html

你可能感兴趣的文章
不错的MVC文章
查看>>
IOS Google语音识别更新啦!!!
查看>>
[置顶] Linux终端中使用上一命令减少键盘输入
查看>>
BootScrap
查看>>
路冉的JavaScript学习笔记-2015年1月23日
查看>>
Mysql出现(10061)错误提示的暴力解决办法
查看>>
2018-2019-2 网络对抗技术 20165202 Exp3 免杀原理与实践
查看>>
Swift - 异步加载各网站的favicon图标,并在单元格中显示
查看>>
【Python学习笔记】1.基础知识
查看>>
梦断代码阅读笔记02
查看>>
selenium学习中遇到的问题
查看>>
大数据学习之一——了解简单概念
查看>>
Linux升级内核教程(CentOS7)
查看>>
Lintcode: Partition Array
查看>>
Maximum Product Subarray
查看>>
[转载] MySQL的四种事务隔离级别
查看>>
QT文件读写
查看>>
C语言小项目-火车票订票系统
查看>>
[Linux]PHP-FPM与NGINX的两种通讯方式
查看>>
Java实现二分查找
查看>>